Antivirus AZAMOS LA SECURITE C'est important Vous avez la parole

Ordinateur lent équipé d'AVAST : aswbidsha frappe encore, par Azamos.

Ordinateur lent équipé d'AVAST : aswbidsha frappe encore, par Azamos.

Votre PC chéri se portait bien, mais depuis quelques temps rien ne va plus : démarrage lent, programmes qui mettent un temps fou à se lancer, et puis arrivent les bugs où plus rien ne répond, la souris se transforme en un rond qui ne cesse de tourner, l’écran devenant blanchâtre, vous obligeant à forcer l’arrêt de votre machine. mur  

Ordinateur lent équipé d'AVAST, solution, image 1.

Pourtant votre ordinateur est sain et à jour, et la ribambelle de scan antiviraux et les tests de vos composants que vous avez lancés à la recherche désespérée du responsable de tout cela vous renvoient tous, AVAST en tête, que : tout va très bien, Madame la marquise. :wacko:

Ne cherchez plus, aswbidsha en est très certainement la cause !

« Mais c’est qui ce « aswbid-machin-chose » ? »

 

Sans rentrer dans les détails (on s’en fout au final bg ), c’est une extension du célébrissime logiciel antivirus AVAST, oui celui qui est le plus utilisé en France (et dans pas mal d’autres pays).

Elle est implémentée dans votre système à hauteur des pilotes de votre Windows… et elle fait bien du tort.

Ordinateur lent équipé d'AVAST, solution, image 2

De son nom complet aswbidsha.sys, cette fonction cause des soucis connus depuis…. Avril 2017 ! Oui, presque 1 an et demi !!!

 

A croire que les équipes d’AVAST se sont endormies sur leurs lauriers.

Toutes les versions de Windows peuvent être touchées, de XP à Windows 10.

Nous allons donc découvrir ensemble comment solutionner le problème, pas-à-pas, histoire que même les moins aguerris d’entre nous y arrivent les doigts dans le nez.

Allez, on commence.  :-)

***

Ordinateur lent équipé d'AVAST : aswbidsha frappe encore

VÉRIFICATION

 

Dans un premier temps on va vérifier si vraiment c’est AVAST la cause de vos soucis.

On va donc démarrer l’ordinateur en « Mode sans échec » (ou « Mode sans échec avec prise en charge réseau », au choix).

Pour Windows 7/Vista/XP, c’est en tapotant sur la touche « F8 » au démarrage du PC.

Pour Windows 8/8.1/10, c’est initialement plus compliqué, mais il existe une astuce facile à appliquer pour retrouver la fonction « F8 » comme sous Win 7 : https://sospc.name/windows-8-activer-f8/ ;-)

  • On tombe donc sur ce menu, et on sélectionne avec les flèches directionnelles du clavier le mode sans échec =>

Ordinateur lent équipé d'AVAST, solution, image 3

On valide avec la touche « Entrée ».

  • Une liste de lignes blanches apparaît et défile à toute vitesse, et d’un coup s’arrête quelques secondes. Là il va falloir être rapide pour lire les derniers mots de la dernière ligne =>

Ordinateur lent équipé d'AVAST, solution, www.sospc.name

Ici c’est « CLASSPNP.SYS » : c’est normalement sur cette ligne que s’arrête temporairement le défilement.

Le souci dans ce cas là ne provient donc pas d’AVAST.

  • Mais si c’est sur ceci que vos lignes se figent =>

Ordinateur lent équipé d'AVAST, solution, image 5

  • La c’est notre « aswbidsha.sys », et donc l’antivirus AVAST est clairement le responsable des bugs à répétition de votre système  :-( =>

Ordinateur lent équipé d'AVAST, solution, image 6

Notez que quelques lignes au-dessus, on retrouve notre «CLASSPNP.SYS » sur lequel le système n’a même pas fait de pause.

L’arrêt ne dure généralement que quelques secondes, mais parfois cela peut durer plus de 1 minute, donc soyez patient (déjà vu 10 minutes et plus).

IMPORTANT : si la ligne en bas de votre page est différente que l’une des 2 que j’ai évoqué ici, je vous conseil d’ouvrir une demande sur le forum d’SOSPC, où vous aurez une aide personnalisée et adaptée à votre cas  :-)  : https://forumsospc.fr/

Bien, on a trouvé notre responsable ; procédons à son éradication. B-)

****

Ordinateur lent équipé d'AVAST : aswbidsha frappe encore, solution.

TÉLÉCHARGEMENT

 

Suivant le cas vous vous trouverez sur la session « mode sans échec avec prise en charge réseau » pour procéder au téléchargement et à l’utilisation de l’utilitaire dont je vais parler, ou bien vous serez sur une session normale.

Je vais exposer ici la méthode depuis une session normale, le tout se rejoignant au final.

Pour commencer on va télécharger l’outil AvastClear.

Cet utilitaire est proposé justement par la société AVAST, permettant une suppression propre de leurs suites de protection.

Rendons-nous sur la page dédiée en cliquant sur le lien suivant : https://www.avast.com/fr-fr/uninstall-utility

  • On se retrouve donc avec cet affichage =>

Ordinateur lent équipé d'AVAST, solution, image 7

Cliquez sur le petit mot bleuté que j’ai entouré : oui, ce n’est pas très évident à trouver, perdu au milieu du paragraphe.

  • Et apparaît la fenêtre habituelle pour le téléchargement. Enregistrez-le sur votre Bureau =>

Ordinateur lent équipé d'AVAST, solution, image 8

  • Voilà les 2 frères ennemis =>

Ordinateur lent équipé d'AVAST, solution, image 9

Celui de droite va péter la gueule à celui de gauche. « BOOnnGG !!! », début du premier rond ! bg

  • On fait un clic-droit sur « AvastClear » et on sélectionne « Exécuter en tant qu’administrateur » =>

Ordinateur lent équipé d'AVAST, solution, image 10

  • Apparaît cette fenêtre =>

Ordinateur lent équipé d'AVAST, solution, image 11

  • Très vite recouverte par celle-ci =>

Ordinateur lent équipé d'AVAST, solution, image 12

  • Cliquez sur « OUI » et nouvel encart =>

Ordinateur lent équipé d'AVAST, solution, image 13

Et on clique à nouveau sur « OUI ».

L’ordinateur redémarre et va tout seul se lancer en « Mode sans échec » sans aucune intervention de votre part : pratique non ?  ;-)

  • Va apparaître, en plus des lignes que l’on a vu plus haut, ceci =>

Ordinateur lent équipé d'AVAST, solution, image 14

« …booting in safemode… » = « démarrage en mode sans échec » (oui, je angliche verri goude parling môa !!!   :yahoo: ).

Le fameux « aswbidsha.sys » est toujours en bas de liste ; on patiente un peu et on arrive sur le Bureau du mode sans échec où apparaît en grand ceci (ici ceux qui ont lancé AvastClear depuis la session « sans échec » nous rejoignent)

  • « BOOnnGG !!! », début du second round ! bg =>

Ordinateur lent équipé d'AVAST, solution, image 15

Si vous n’avez pas pendant l’installation d’AVAST (oui, je sais, ça remonte à loin parfois) désigné un emplacement particulier, alors laissez tout comme cela pour les 2 premières lignes

En « 1 » changez le cas échéant l’édition d’AVAST que vous utilisez. Par défaut c’est sur Avast gratuit.

Une fois tout calé, cliquez sur le bouton « Désinstaller ».

  • La désinstallation se lance =>

Ordinateur lent équipé d'AVAST, solution, image 16

  • C’est rapide, et apparaît cette dernière fenêtre =>

Ordinateur lent équipé d'AVAST, solution, image 17

Cliquez sur « Redémarrer l’ordinateur ».

  • Une fois revenu sur votre Bureau habituel, on constate la disparition de l’antivirus =>

Ordinateur lent équipé d'AVAST, solution, image 18

Testez la stabilité de votre système en lançant plein d’applications, en ouvrant des dizaines de fenêtres, bref, le but est de pousser un peu votre PC pour voir si tout est bien rentré dans l’ordre.  :-)

Tout est bon ! « BOOnnGG !!! » AvastClear vainqueur par K.O !!! BluesB

***

Ordinateur lent équipé d'AVAST, la solution

ET APRÈS ?

 

« Parfait ! Tout est fonctionnel ! Mais maintenant je n’ai plus d’antivirus : je fais quoi ? »

Eh oui, hors de question de nos jours d’avoir un PC sans protection. 3 possibilités s’offrent à vous :

  1. Vous réinstallez AVAST : je n’ai pas réellement tenu de compte, mais j’estime entre 80 et 120 (oui, je ratisse large bg ) les fois où j’ai rencontré ce bug, avec une belle pointe ces derniers jours. Dans la très grande majorité des cas le bug ne s’est pas reproduit. Donc la réinstallation est toujours possible.

Pour l’anecdote, l’un des 2 PC qui m’ont servit à faire les captures et tests pour cet article re-déclenchait immédiatement le bug une fois AVAST réinstallé.

  • C’est en voulant renommer le fichier « capture » que vous voyez sur l’image ci-dessous que j’ai eu le message d’erreur et le voile blanc sur mon écran ;-) =>

Ordinateur lent équipé d'AVAST, solution sur sospc.name

Mais dès qu’AvastClear était appliqué, plus de soucis ! tropbien . Donc vous pouvez retenter l’expérience si le cœur vous en dit. A retenir que en installant/réinstallant AVAST ce doit bien être "CLASSPNP.SYS" qui doit apparaître en lançant le "mode sans échec".

  1. Vous passez à un autre antivirus gratuit : il y en a plein à votre disposition, mais au choix je vous conseille Kaspersky Free : https://sospc.name/kaspersky-free-antivirus-2019/
  1. Vous passez à une Suite de Sécurité payante : personnellement je n’en recommande que 2, qui sont Kaspersky Internet Security (https://sospc.name/kaspersky-internet-security-2019-nouveautes/ ) et Bitdefender Internet Security.

Oui, ce n’est pas gratuit… mais combien va vous coûter les services d’un professionnel en cas de clash ?

Sans parler des usages frauduleux qui pourraient être fait avec vos comptes mails ou bancaires hackés (démarches auprès des organismes, dépôt de plainte, etc…).

Pour une douzaine d'euros par an, le jeu en vaut vraiment la chandelle. Je dis ça, je dis rien…. :whistle:

***

Ordinateur lent équipé d'AVAST FAQ

FAQ

 

«  Pourquoi ne pas en avoir parlé plus tôt sur SOSPC, vu que cela date de début 2017 ? »

Faute à moi, j’avoue : les premiers cas que j’ai rencontrés à cette époque, et bien je n’avais pas toujours le temps, ou bien pas eu l’idée sur le coup de prendre des photos et captures d’écran. Et puis je me disais que les équipes d’AVAST allez régler tout cela rapidement : grave erreur, c’est toujours d’actualité … :cry:

«  Je n’arrive pas du tout à démarrer en « mode sans échec », même avec l’utilitaire d’AVAST »

J’ai rencontré 2 fois le cas : c’était sur des PC très infectés par des malwares et autres bestioles, pas entretenus par leurs propriétaires (« tant que ça marche je joue »… :negative: ). Bien que AvastClear recommande de l’utiliser en mode sans échec, il est tout à fait possible de l’utiliser en mode « normal » ; bien entendu à ne faire que dans ce cas particulier.

« J’avais bien « aswbidsha » qui apparaissait et j’ai désinstallé AVAST, mais mon système est toujours aussi lent »

C’est clairement une accumulation de causes : disque dur défaillant, malwares, système pas mis à jour, etc…

Si vous êtes sous Windows 7, il est aussi possible que vous soyez en plus victime de ce bug que je décris ici : https://sospc.name/windows-7-bug-windows-update/

**********

Voilà, fin de ce tutoriel.

J’espère qu’il vous aura permis de solutionner vos soucis, ou au moins d’apprendre certaines choses, comme par exemple le démarrage en mode sans échec, très utile dans beaucoup de cas à connaitre.  ;-)

La zone de commentaires vous tend les bras, alors ne soyez pas timide.  :-)

A très bientôt !

AZAMOS

Azamos Contributeur Sospc

Les autres articles d'AZAMOS :  

 

autres articles

***

écrire un article sur sospc.name

Vous avez envie comme Azamos de publier sur Sospc sur un sujet qui vous passionne ?

Je vous propose de vous rendre ICI pour en savoir plus si vous êtes intéressé.

Christophe, Administrateur.

Christophe Webmaster Sospc.name Rejoignez la Communauté SOSPC et accédez à des contenus et des avantages exclusifs à partir d'1,70€/Mois avec l'abonnement annuel ! Cliquez ICI pour obtenir plus d'infos et consulter tous les abonnements disponibles. ;-)

Christophe. Administrateur.

Laisser un Commentaire

:bye: 
:good: 
:negative: 
:scratch: 
:wacko: 
:yahoo: 
B-) 
:-) 
:whistle: 
:yes: 
:cry: 
:mail: 
:-( 
:unsure: 
;-) 
tropbien 
mdr 
bg 
DieuD 
sos 
js 
pfe 
vv 
pcccccccc 
mur 
bdj 
BluesB 
tg 
CSCP 
cr 
 

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.

27 Commentaires

  • Bonjour, je parviens à démarrer en mode sans échec sous windows 8, en revanche aucun défilement de toutes les lignes sur fond noir. Je ne peux donc pas voir sur quelle ligne ça fait une pause. Est-ce qu'il y a un moyen pour voir ces lignes ou est-ce que je fais la manip sans vérification ? En sachant que mon seul problème est que les vidéos et les mp3 mettent un temps fou à démarrer et que quand je neutralise Avast, je n'ai plus ce problème.
    Merci

    • Bonjour Christian,

      En effet sous Windows 8/10 il n'y a pas ce défilement. Il est possible de voir ce défilement mais c'est complexe à réaliser.

      De toute façon le constat est là : Avast provoque un bug sur votre système (d'ailleurs depuis plusieurs mois il est à l'origine d'autres bugs que celui décrit ici). Je vous conseille donc de le supprimer définitivement et de basculer sur un autre antivirus. :yes:

  • Bjr :bye:

    Bon je vais donc tester Kaspersky Free ai testé un redémarrage en mode sans Echec.

    Cela se fige très peu de temps (2 sec) sur CLASSPNP.SYS enfin c'est pas énorme :unsure:

    Donc à qui ou à quoi correspond ce fichier ?

    GG

    • Bonjour GEGEPING,

      Comme je l'ai dis sur le tuto, l'arrêt sur le "CLASSPNP.SYS" est tout à fait normal.

      Ensuite qu'il ne s'arrête que quelques secondes est là aussi normal, et je dirai même mieux : un temps de 2 secondes est très bon signe ;-)

      • Re :bye:

        C'est rassurant alors :yahoo:

        Ce que j'ai constaté c'est avec Avast et donc redémarrage en mode sans echec ça s'arrête autant de temps sur la ligne du fichier avast mais ne s'arrête pas sur le clas..

        Alors Avast est il gourmand en mémoire même en sans echec ou mal fini???

        J'ai donc passé mon D630 sous Seven pro 64 avec KasperskyFree.

        Je verrais à l'usage si je passe I'I7 sous 8.1 64 aussi et au delà si satisfaisant.

        GG